Перейти к содержимому

Форум ZiSMO.biz


Купить ссылку здесь
Фотография
- - - - -

Запросы к API ВКонтакте c версией ниже 5.0 перестанут поддерживаться.Отказ от мажорных версий API.

Форум ZiSMO.biz
ВКонтакте
0
В этой теме нет ответов

OFFLINE Отправлено

Правый Наушник
Продвинутый
  • Онлайн:133д 2ч 11м
992

Весна — время обновлений. Очищаем балконы от старых лыж и API от устаревших версий: уже скоро запросы к API c версией ниже 5.0 перестанут поддерживаться.

Ожидаемая дата изменений: 15 мая 2019 года. 

 

Отказ от мажорных версий API 3.0 и 4.0

На этой странице мы рассказываем об одном из будущих изменений платформы API ВКонтакте. Чтобы посмотреть список всех недавних и грядущих изменений, перейдите к этой странице.

1. Как это работает сейчас 
2. Что изменится 
3. Как подготовиться к изменениям 

Ожидаемая дата изменений: 15 мая 2019 года

От версии к версии в API меняются названия полей, типы данных в них, структура объектов. Чтобы корректно обрабатывать в своем приложении ответы от методов API, важно наперед знать, какие данные и в каком виде придут от сервера. Задавая номер версии в своем вызове, Вы сообщаете серверу, какой формат данных Вы ожидаете получить в ответе. 

В 2014 году было запущено глобальное обновление API, затрагивающее почти все методы, объекты и их поля. Но ещё долгое время не могли отказаться от использования устаревших версий, поскольку для нас важно поддерживать совместимость платформы со старыми приложениями, которыми по-прежнему пользуются многие люди. Но необходимость их поддержки накладывает всё большие ограничения на дальнейшее развитие платформы, в связи с чем мы приняли решение отказаться от версий ниже 5.0.

 

 

1. Как это работает сейчас

После отказа версий по умолчанию для сохранения совместимости в приложениях многие разрабочики указали версии ниже 5.0
Но мажорные версии 3.0 и 4.0 являются устаревшими, в них не поддержаны многие типы объектов, а формат ответа у большинства методов совсем не похож на тот, что Вы видите в примерах документации.

 
2. Что изменится
Запросы к API c указанной мажорной версией 3.0 и 4.0 перестанут поддерживаться. Сервер вернет ошибку на запрос к API, в котором указана версия ниже 5.0.
 
3. Как подготовиться к изменениям
Структура объектов и названия полей в версии 5.0 почти всегда отличаются от используемых в 3.0 и 4.0. Вам необходимо актуализировать код на основе нашей документации. Основные изменения, которые нужно учесть при переходе на версию 5.0, указаны здесь

Список изменений в версиях доступен здесь: https://vk.com/dev/versions

Подробности в Roadmap: https://vk.com/dev/version_update_2.0

Источник 

ВКонтакте API https://vk.com/apiclub

 

В теме можно обозначить всё что перестанет работь ВКонтакте (

 


Сообщение отредактировал Правый Наушник: 11 04 2019 - 23:24

    • 0
  • Наверх
  • Ответить

Поделиться этим:


Напишите сообщение